□ 개요
o Genivia社의 오픈 소스 소프트웨어 개발 라이브러리인 gSOAP에서 원격 코드 실행이 가능한 취약점 발견 [1]
※ gSOAP : SOAP/XML 웹 서비스 및 일반 XML 데이터 처리를 위한 C/C++ 소프트웨어 개발 툴킷으로, 가볍고 이식성이
높아 IP 카메라 등 IoT 기기에 사용됨
o 취약한 버전을 사용 중인 개발 담당자는 서비스 거부 공격, 악성코드 감염 등의 위험이 있으므로 아래 해결 방안에 따른
조치 권고

□ 내용
o gSOAP 라이브러리 내 soap_get() 함수에서 정수 오버플로우가 발생하여 임의 코드 실행을 가능하게 하는 취약점
(CVE-2017-9765)

□ 영향을 받는 버전
o Genivia gSOAP 2.8.48 미만 버전

□ 해결 방안
o 취약점에 영향을 받지 않는 버전으로 업데이트 수행
- Genivia gSOAP 2.8.48 이상 버전 [2]
※ 최신 버전은 Genivia gSOAP 2.8.50 버전


[참고사이트]
[1] https://www.genivia.com/advisory.html#Security_advisory:_CVE-2017-9765_bug_in_certain_versions_of_gSOAP_2.7_up_to_2.8.47_%28June_21,_2017%29
[2] https://www.genivia.com/downloads.html

저작자 표시 비영리 변경 금지
신고
블로그 이미지

Ryansecurity Ryansecurity

Life is fun security story

Tag

티스토리 툴바